Frequently Asked Question
Symptom:
You send a message from Outlook on the desktop (not on the web). While composing the message you get a message that says invalid recipient or you get a message in response that says the user can't be found after you click send.
Cause:
Your Outlook Address Book maintains an "Autocomplete" list of people you have emailed before. Unfortunately, it stores an ID for the person, rather than their real email address. After an email server change or a username change for the user you're emailing, Outlook can't find the right mailbox.
Solution:
You have two options - Clear the single entry, or clear your entire autocomplete cache.
Clear a Single Entry
1. In the Outlook main window, create a new email by clicking on the New Email icon at the top left
2. In the To field, start typing the email address or the name of the contact you would like to clear from the autocomplete cache. It appears listed in a tool-tip. Press the down arrow key to select the right contact if there are more than one proposed.
3.Click the delete (X) icon to permanently remove the autocomplete entry you selected.
Clear all entries
1. In the Outlook main window, click the File menu in the top left
2. From the File menu, click the Options button
3. In Options, click the Mail tab and scroll down to the Send Messages section
4. Click the Empty Auto-Complete List button
5. A confirmation box will appear, click Yes. The AutoComplete cache will be completely erased.